Download Concierge 2.0

Requirements: Sun Java Runtime Environment 1.5

These are stand-alone software.

All-In-One packages

Including iPapers(literature manager) and LabNote(electronic laboratory notebook) plug-ins.

Core packages

Only storeing to database and searching files.


Concierge Eclipse plug-ins

Requirements: Eclipse 3.3 or 3.4

Concierge can be simply installed from within Eclipse using update manager.